$re = '/"html_content"\s*:\s*"(.*?(?<!\\\\))"/';
$str = ' "meta_description": "Singapore Company Profile - Azric International Business Services Pte Ltd - Management Consultants, Business Services, Business Consultants ",
"html_content": "<html>\\n <head><\\/head>\\n <body>\\n Azric International Business Services Pte Ltd - Management Consultants, Business Services, Business Consultants, Singapore Companies Directory \\n <table> \\n <tbody> \\n <tr> \\n <td> \\n <table> \\n <tbody> \\n <tr> \\n <td> \\n <table> \\n <tbody> \\n <tr> \\n <td> <\\/td> \\n <td> <\\/td> \\n <td> <\\/td> \\n <\\/tr> \\n <tr> \\n <td> <\\/td> \\n <td> \\n <table> \\n <tbody> \\n <tr> \\n <td> <a href=\\"http://singapore-companies-directory.com\\" target=\\"_blank\\"> Main<\\/a><\\/td> \\n <td> <a href=\\"http://singapore-companies-directory.com/aboutus.htm\\" target=\\"_blank\\"> About Us<\\/a><\\/td> \\n <td> <a href=\\"http://singapore-companies-directory.com/products", "other_data": 1
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);