import Foundation
let pattern = #""html_content"\s*:\s*"(.*?(?<!\\))""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"meta_description": "Singapore Company Profile - Azric International Business Services Pte Ltd - Management Consultants, Business Services, Business Consultants ",
"html_content": "<html>\n <head><\/head>\n <body>\n Azric International Business Services Pte Ltd - Management Consultants, Business Services, Business Consultants, Singapore Companies Directory \n <table> \n <tbody> \n <tr> \n <td> \n <table> \n <tbody> \n <tr> \n <td> \n <table> \n <tbody> \n <tr> \n <td> <\/td> \n <td> <\/td> \n <td> <\/td> \n <\/tr> \n <tr> \n <td> <\/td> \n <td> \n <table> \n <tbody> \n <tr> \n <td> <a href=\"http://singapore-companies-directory.com\" target=\"_blank\"> Main<\/a><\/td> \n <td> <a href=\"http://singapore-companies-directory.com/aboutus.htm\" target=\"_blank\"> About Us<\/a><\/td> \n <td> <a href=\"http://singapore-companies-directory.com/products", "other_data": 1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}