#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*(?<type>fix|refactor|build)(?<scope>\(.*\))?(?<breaking>!)?:? ?(?<subject>.*$)?.*"
Local $sString = "build(lol!: test xxx xx" & @CRLF & _
"build: test" & @CRLF & _
"build(()): test" & @CRLF & _
"build(test:module!lol)!: test" & @CRLF & _
"build(: " & @CRLF & _
"build" & @CRLF & _
"fix: "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")