import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(?<type>fix|refactor|build)(?<scope>\\(.*\\))?(?<breaking>!)?:? ?(?<subject>.*$)?.*";
final String string = "build(lol!: test xxx xx\n"
+ "build: test\n"
+ "build(()): test\n"
+ "build(test:module!lol)!: test\n"
+ "build(: \n"
+ "build\n"
+ "fix: ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}