package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(?<type>fix|refactor|build)(?<scope>\(.*\))?(?<breaking>!)?:? ?(?<subject>.*$)?.*`)
var str = `build(lol!: test xxx xx
build: test
build(()): test
build(test:module!lol)!: test
build(:
build
fix: `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}