// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*(?<type>fix|refactor|build)(?<scope>\(.*\))?(?<breaking>!)?:? ?(?<subject>.*$)?.*").unwrap();
let string = "build(lol!: test xxx xx
build: test
build(()): test
build(test:module!lol)!: test
build(:
build
fix: ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}