import re
regex = re.compile(r"\"([23]{1,7})\"")
test_str = "\"3\"sca\"\"\"co\"1\"str\"0\"ctor\"\"r\"3\"t\"0\"r\"1\"\"locat\"5\"o\"133\"\"0\"27\"\"754a49b393c2a0\"33\"b97\"332\"cb7\"3\"c3c07\"2\"\"co\"1\"str\"0\"ct\"233223322\"or\"\"r\"3\"t\"0\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")