// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""([23]{1,7})""#).unwrap();
let string = "\"3\"sca\"\"\"co\"1\"str\"0\"ctor\"\"r\"3\"t\"0\"r\"1\"\"locat\"5\"o\"133\"\"0\"27\"\"754a49b393c2a0\"33\"b97\"332\"cb7\"3\"c3c07\"2\"\"co\"1\"str\"0\"ct\"233223322\"or\"\"r\"3\"t\"0\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}