re = /"([23]{1,7})"/
str = '"3"sca"""co"1"str"0"ctor""r"3"t"0"r"1""locat"5"o"133""0"27""754a49b393c2a0"33"b97"332"cb7"3"c3c07"2""co"1"str"0"ct"233223322"or""r"3"t"0"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end