use strict;
my $str = '616-555-1212
555-1212
6165551212
asdf
1
800-111-2222
800-111-2222d
800-11a-2222
.
112
-
';
my $regex = qr/^\d{3}-\d{3}-\d{4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}