import re
regex = re.compile(r"^\d{3}-\d{3}-\d{4}$", flags=re.MULTILINE)
test_str = ("616-555-1212\n"
"555-1212\n"
"6165551212\n"
"asdf\n"
"1\n"
"800-111-2222\n"
"800-111-2222d\n"
"800-11a-2222\n"
".\n"
"112\n"
"-\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")