re = /^\d{3}-\d{3}-\d{4}$/m
str = '616-555-1212
555-1212
6165551212
asdf
1
800-111-2222
800-111-2222d
800-11a-2222
.
112
-
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end