using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!(?:JOHN|I)\b)(?:[A-Z]{1,8}[0-9]?|[0-9]{2,3})\b";
string input = @"JOHN went to LONDON one fine day. JOHN had lunch in a PUB. JOHN then moved to CHICAGO. I don't want JOHN to be highlighted. John does not want this to match the pattern. Neither this. But THIS1 should match the pattern. Also the other 70 times that the pattern should match.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}