const regex = /\b(?!(?:JOHN|I)\b)(?:[A-Z]{1,8}[0-9]?|[0-9]{2,3})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!(?:JOHN|I)\\b)(?:[A-Z]{1,8}[0-9]?|[0-9]{2,3})\\b', 'g')
const str = `JOHN went to LONDON one fine day. JOHN had lunch in a PUB. JOHN then moved to CHICAGO. I don't want JOHN to be highlighted. John does not want this to match the pattern. Neither this. But THIS1 should match the pattern. Also the other 70 times that the pattern should match.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}