import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!(?:JOHN|I)\\b)(?:[A-Z]{1,8}[0-9]?|[0-9]{2,3})\\b";
final String string = "JOHN went to LONDON one fine day. JOHN had lunch in a PUB. JOHN then moved to CHICAGO. I don't want JOHN to be highlighted. John does not want this to match the pattern. Neither this. But THIS1 should match the pattern. Also the other 70 times that the pattern should match.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}