using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^l+[0-9]+@hotmail.com$";
string input = @"samuel7348@hotmail.com
aa1@hotmail.com
some.day.ill.be.saturday.night1995@hotmail.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}