re = /^l+[0-9]+@hotmail.com$/m
str = 'samuel7348@hotmail.com
aa1@hotmail.com
some.day.ill.be.saturday.night1995@hotmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end