use strict;
my $str = 'samuel7348@hotmail.com
aa1@hotmail.com
some.day.ill.be.saturday.night1995@hotmail.com';
my $regex = qr/^l+[0-9]+@hotmail.com$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}