#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^[^_]*_"
Local $sString = "1_anotherTest"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)