use strict;
my $str = '1_anotherTest';
my $regex = qr/^[^_]*_/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";