using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^_]*_";
string substitution = @"";
string input = @"1_anotherTest";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}