#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^<([^>]+)>(?:(?!\1).)+</\1>$"
Local $sString = "<center>Random question</center>" & @CRLF & _
"center Text" & @CRLF & _
"Text center" & @CRLF & _
"<center>Random center question</center>" & @CRLF & _
"<p>Random question</p> <strong>center</strong>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")