using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<([^>]+)>(?:(?!\1).)+</\1>$";
string input = @"<center>Random question</center>
center Text
Text center
<center>Random center question</center>
<p>Random question</p> <strong>center</strong>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}