$re = '@^<([^>]+)>(?:(?!\1).)+</\1>$@m';
$str = '<center>Random question</center>
center Text
Text center
<center>Random center question</center>
<p>Random question</p> <strong>center</strong>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);