package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(495\) 123-4(111|222|333)`)
var str = `(495) 123-4111
(495) 123-4111
(495) 123-4222`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}