re = /\(495\) 123-4(111|222|333)/
str = '(495) 123-4111
(495) 123-4111
(495) 123-4222'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end