const regex = /\(495\) 123-4(111|222|333)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(495\\) 123-4(111|222|333)', 'g')
const str = `(495) 123-4111
(495) 123-4111
(495) 123-4222`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}