$re = '/\(495\) 123-4(111|222|333)/';
$str = '(495) 123-4111
(495) 123-4111
(495) 123-4222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);