#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\"SELECT([^"]|\n|\"[^";]*\")*LIMIT([^"]|\n|\"[^";]*\")*\";"
Local $sString = "// blah" & @CRLF & _
"$SelQuery = "SELECT DISTICNT C.firstname,C.lastname,C.id as clientid,QC.category_name,QR.cid,QR.catid,QR.rhid" & @CRLF & _
" FROM cms_question_report QR, cms_clients C,cms_questioncategory QC ,cms_reporthistory RH" & @CRLF & _
" WHERE C.id=QR.cid" & @CRLF & _
" AND QR.rhid=RH.id" & @CRLF & _
" AND QR.catid='".$objArray['catid']."'" & @CRLF & _
" AND QR.catid=QC.id" & @CRLF & _
" AND C.id IN($SelClids)" & @CRLF & _
" LIMIT $page_no,$this->Limit";" & @CRLF & _
"" & @CRLF & _
"$SelQuery = "SELECT DISTICNT C.firstname,C.lastname,C.id as clientid,QC.category_name,QR.cid,QR.catid,QR.rhid" & @CRLF & _
" FROM cms_question_report QR, cms_clients C,cms_questioncategory QC ,cms_reporthistory RH" & @CRLF & _
" WHERE C.id=QR.cid" & @CRLF & _
" AND QR.rhid=RH.id" & @CRLF & _
" AND QR.catid='".$objArray['catid']."'" & @CRLF & _
" AND QR.catid=QC.id" & @CRLF & _
" AND C.id IN($SelClids)";" & @CRLF & _
"" & @CRLF & _
""SELECT LIMIT";" & @CRLF & _
"LIMIT" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")