import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"SELECT([^\"]|\\n|\\\"[^\";]*\\\")*LIMIT([^\"]|\\n|\\\"[^\";]*\\\")*\\\";";
final String string = "// blah\n"
+ "$SelQuery = \"SELECT DISTICNT C.firstname,C.lastname,C.id as clientid,QC.category_name,QR.cid,QR.catid,QR.rhid\n"
+ " FROM cms_question_report QR, cms_clients C,cms_questioncategory QC ,cms_reporthistory RH\n"
+ " WHERE C.id=QR.cid\n"
+ " AND QR.rhid=RH.id\n"
+ " AND QR.catid='\".$objArray['catid'].\"'\n"
+ " AND QR.catid=QC.id\n"
+ " AND C.id IN($SelClids)\n"
+ " LIMIT $page_no,$this->Limit\";\n\n"
+ "$SelQuery = \"SELECT DISTICNT C.firstname,C.lastname,C.id as clientid,QC.category_name,QR.cid,QR.catid,QR.rhid\n"
+ " FROM cms_question_report QR, cms_clients C,cms_questioncategory QC ,cms_reporthistory RH\n"
+ " WHERE C.id=QR.cid\n"
+ " AND QR.rhid=RH.id\n"
+ " AND QR.catid='\".$objArray['catid'].\"'\n"
+ " AND QR.catid=QC.id\n"
+ " AND C.id IN($SelClids)\";\n\n"
+ "\"SELECT LIMIT\";\n"
+ "LIMIT\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}