const regex = /\"SELECT([^"]|\n|\"[^";]*\")*LIMIT([^"]|\n|\"[^";]*\")*\";/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"SELECT([^"]|\\n|\\"[^";]*\\")*LIMIT([^"]|\\n|\\"[^";]*\\")*\\";', 'g')
const str = `// blah
\$SelQuery = "SELECT DISTICNT C.firstname,C.lastname,C.id as clientid,QC.category_name,QR.cid,QR.catid,QR.rhid
FROM cms_question_report QR, cms_clients C,cms_questioncategory QC ,cms_reporthistory RH
WHERE C.id=QR.cid
AND QR.rhid=RH.id
AND QR.catid='".\$objArray['catid']."'
AND QR.catid=QC.id
AND C.id IN(\$SelClids)
LIMIT \$page_no,\$this->Limit";
\$SelQuery = "SELECT DISTICNT C.firstname,C.lastname,C.id as clientid,QC.category_name,QR.cid,QR.catid,QR.rhid
FROM cms_question_report QR, cms_clients C,cms_questioncategory QC ,cms_reporthistory RH
WHERE C.id=QR.cid
AND QR.rhid=RH.id
AND QR.catid='".\$objArray['catid']."'
AND QR.catid=QC.id
AND C.id IN(\$SelClids)";
"SELECT LIMIT";
LIMIT
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}