#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\B%[a-z0-9]+\b"
Local $sString = "1. %xxxxxxxxxxxxx //match" & @CRLF & _
"2. this will work %xxxxxx but not this%xxxxxxxxx. //match 1st, not 2nd" & @CRLF & _
"3. and also %xxxxxxxxxx. //match" & @CRLF & _
"4. just a line ending with %xxxxxxxxxxx //match" & @CRLF & _
"5. %Xxxxxxxxxxx //no match" & @CRLF & _
"6. 100% of dogs //no match" & @CRLF & _
"7. 65%. Begining of new phrase //no match" & @CRLF & _
"8. 65%.Begining of new phrase //no match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")