package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\B%[a-z0-9]+\b`)
var str = `1. %xxxxxxxxxxxxx //match
2. this will work %xxxxxx but not this%xxxxxxxxx. //match 1st, not 2nd
3. and also %xxxxxxxxxx. //match
4. just a line ending with %xxxxxxxxxxx //match
5. %Xxxxxxxxxxx //no match
6. 100% of dogs //no match
7. 65%. Begining of new phrase //no match
8. 65%.Begining of new phrase //no match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}