import re
regex = re.compile(r"\B%[a-z0-9]+\b")
test_str = ("1. %xxxxxxxxxxxxx //match\n"
"2. this will work %xxxxxx but not this%xxxxxxxxx. //match 1st, not 2nd\n"
"3. and also %xxxxxxxxxx. //match\n"
"4. just a line ending with %xxxxxxxxxxx //match\n"
"5. %Xxxxxxxxxxx //no match\n"
"6. 100% of dogs //no match\n"
"7. 65%. Begining of new phrase //no match\n"
"8. 65%.Begining of new phrase //no match")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")