package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:go|h[1,3]\-redir02\-v)\.eset\.com|(?:support\-)?go\.eset\.eu$`)
var str = `go.eset.com
h1-redir02-v.eset.com
h3-redir02-v.eset.com
go.eset.eu
support-go.eset.eu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}