const regex = /^(?:go|h[1,3]\-redir02\-v)\.eset\.com|(?:support\-)?go\.eset\.eu$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:go|h[1,3]\\-redir02\\-v)\\.eset\\.com|(?:support\\-)?go\\.eset\\.eu$', 'gmi')
const str = `go.eset.com
h1-redir02-v.eset.com
h3-redir02-v.eset.com
go.eset.eu
support-go.eset.eu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}