import re
regex = re.compile(r"^(?:go|h[1,3]\-redir02\-v)\.eset\.com|(?:support\-)?go\.eset\.eu$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("go.eset.com\n"
"h1-redir02-v.eset.com\n"
"h3-redir02-v.eset.com\n"
"go.eset.eu\n"
"support-go.eset.eu")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")