#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)@if\((?P<condition>.*)\)\n*\s*(?P<content>(?s:[\=\"\s\/\<\>\w\n]*))@endif"
Local $sString = "@if('eee' == 'esee')" & @CRLF & _
" <h2>Test</h2>" & @CRLF & _
"@endif" & @CRLF & _
"" & @CRLF & _
"@if('aaa' == 'aaa')" & @CRLF & _
" <h2>Test</h2>" & @CRLF & _
" <div class="test">test</div>" & @CRLF & _
"@endif"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")