import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@if\\((?P<condition>.*)\\)\\n*\\s*(?P<content>(?s:[\\=\\\"\\s\\/\\<\\>\\w\\n]*))@endif";
final String string = "@if('eee' == 'esee')\n"
+ " <h2>Test</h2>\n"
+ "@endif\n\n"
+ "@if('aaa' == 'aaa')\n"
+ " <h2>Test</h2>\n"
+ " <div class=\"test\">test</div>\n"
+ "@endif";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}