const regex = /@if\((?P<condition>.*)\)\n*\s*(?P<content>(?s:[\=\"\s\/\<\>\w\n]*))@endif/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@if\\((?P<condition>.*)\\)\\n*\\s*(?P<content>(?s:[\\=\\"\\s\\\/\\<\\>\\w\\n]*))@endif', 'gm')
const str = `@if('eee' == 'esee')
<h2>Test</h2>
@endif
@if('aaa' == 'aaa')
<h2>Test</h2>
<div class="test">test</div>
@endif`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}