using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@if\((?P<condition>.*)\)\n*\s*(?P<content>(?s:[\=\""\s\/\<\>\w\n]*))@endif";
string input = @"@if('eee' == 'esee')
<h2>Test</h2>
@endif
@if('aaa' == 'aaa')
<h2>Test</h2>
<div class=""test"">test</div>
@endif";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}