#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "aa|bb|cc|dd|ee|ff|gg|hh|ii|jj|kk|ll|oo|pp"
Local $sString = "been, beer, beet, beep, bell, boom, boot, book, bull, butt, call, cell, coon, dell, doll, door, doom, fall, fell, feel, feet, foot, food, fool, fuss, full, gull, gall, hall, hell, heed, heel, hill, hull, hoop, hood, hoof, hoot, Jeff, jeep, Jill, Judd, keen, keel, keep, less, lees, Matt, mall, need, peel, pall, pool, poof, poll, poor, peek, pass, root, reel, reef, reed, roll, room, rood, sass, sell, seen, seem, seed, seek, seer, seep, soon, soot, sill, tall, tell, teen, teem, teed, Todd, tool, wall, well, watt, weed, week, and weep."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")