// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"aa|bb|cc|dd|ee|ff|gg|hh|ii|jj|kk|ll|oo|pp").unwrap();
let string = "been, beer, beet, beep, bell, boom, boot, book, bull, butt, call, cell, coon, dell, doll, door, doom, fall, fell, feel, feet, foot, food, fool, fuss, full, gull, gall, hall, hell, heed, heel, hill, hull, hoop, hood, hoof, hoot, Jeff, jeep, Jill, Judd, keen, keel, keep, less, lees, Matt, mall, need, peel, pall, pool, poof, poll, poor, peek, pass, root, reel, reef, reed, roll, room, rood, sass, sell, seen, seem, seed, seek, seer, seep, soon, soot, sill, tall, tell, teen, teem, teed, Todd, tool, wall, well, watt, weed, week, and weep.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}