using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"aa|bb|cc|dd|ee|ff|gg|hh|ii|jj|kk|ll|oo|pp";
string input = @"been, beer, beet, beep, bell, boom, boot, book, bull, butt, call, cell, coon, dell, doll, door, doom, fall, fell, feel, feet, foot, food, fool, fuss, full, gull, gall, hall, hell, heed, heel, hill, hull, hoop, hood, hoof, hoot, Jeff, jeep, Jill, Judd, keen, keel, keep, less, lees, Matt, mall, need, peel, pall, pool, poof, poll, poor, peek, pass, root, reel, reef, reed, roll, room, rood, sass, sell, seen, seem, seed, seek, seer, seep, soon, soot, sill, tall, tell, teen, teem, teed, Todd, tool, wall, well, watt, weed, week, and weep.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}