use strict;
my $str = 'been, beer, beet, beep, bell, boom, boot, book, bull, butt, call, cell, coon, dell, doll, door, doom, fall, fell, feel, feet, foot, food, fool, fuss, full, gull, gall, hall, hell, heed, heel, hill, hull, hoop, hood, hoof, hoot, Jeff, jeep, Jill, Judd, keen, keel, keep, less, lees, Matt, mall, need, peel, pall, pool, poof, poll, poor, peek, pass, root, reel, reef, reed, roll, room, rood, sass, sell, seen, seem, seed, seek, seer, seep, soon, soot, sill, tall, tell, teen, teem, teed, Todd, tool, wall, well, watt, weed, week, and weep.';
my $regex = qr/aa|bb|cc|dd|ee|ff|gg|hh|ii|jj|kk|ll|oo|pp/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}