#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]-?){8}\b$"
Local $sString = "12345678" & @CRLF & _
"123456-78" & @CRLF & _
"1234-5678" & @CRLF & _
"1-2-3-4-5-6-7-8" & @CRLF & _
"" & @CRLF & _
"1-2-246-7-3-5-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")