package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]-?){8}\b$`)
var str = `12345678
123456-78
1234-5678
1-2-3-4-5-6-7-8
1-2-246-7-3-5-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}