const regex = /^([0-9]-?){8}\b$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9]-?){8}\\b$', 'gm')
const str = `12345678
123456-78
1234-5678
1-2-3-4-5-6-7-8
1-2-246-7-3-5-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}