$re = '/^([0-9]-?){8}\b$/m';
$str = '12345678
123456-78
1234-5678
1-2-3-4-5-6-7-8
1-2-246-7-3-5-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);