# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'[^']*'(*SKIP)(*F)|\s+/\n/gm;t' <<< "dateto:'2015-10-07 15:05' xxxx datefrom:'2015-10-09 15:05' yyyy asdf"